aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/debian
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2021-03-12 16:10:08 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2021-03-12 16:51:05 +0300
commit73fbcbd41b74ab4e0ff702c4e307334b16038229 (patch)
tree27886e476be340e8ed62c39b0d505f822f01ebf3 /debian
parentdebian: 0.0.2-1 (diff)
downloadlinux-status-73fbcbd41b74ab4e0ff702c4e307334b16038229.tar.gz
linux-status-73fbcbd41b74ab4e0ff702c4e307334b16038229.zip
debian: add GitHub workflow
Diffstat (limited to '')
-rw-r--r--debian/Makefile5
-rw-r--r--debian/Vagrantfile4
2 files changed, 7 insertions, 2 deletions
diff --git a/debian/Makefile b/debian/Makefile
index 5152fdc..51aefa4 100644
--- a/debian/Makefile
+++ b/debian/Makefile
@@ -37,6 +37,11 @@ build_area := $(this_dir)/build-area
.PHONY: DO
DO:
+.PHONY: deps
+deps:
+ apt-get update
+ apt-get install -y build-essential devscripts dh-make git-buildpackage
+
.PHONY: dch
dch:
gbp dch --distribution=unstable
diff --git a/debian/Vagrantfile b/debian/Vagrantfile
index 6202207..ab1decb 100644
--- a/debian/Vagrantfile
+++ b/debian/Vagrantfile
@@ -62,8 +62,8 @@ echo 'StreamLocalBindUnlink yes' >> /etc/ssh/sshd_config
config.vm.provision "shell", inline: <<-SHELL
#!/usr/bin/env bash
set -o errexit -o nounset -o pipefail
-apt-get update
-apt-get install -y build-essential devscripts dh-make git-buildpackage
+apt-get update && apt-get install -y make
+cd /vagrant/debian && make deps
SHELL
config.vm.provision :reload