aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/.gitignore1
-rw-r--r--debian/Makefile28
-rw-r--r--debian/changelog5
-rw-r--r--debian/control14
-rw-r--r--debian/copyright39
-rw-r--r--debian/gbp.conf7
-rw-r--r--debian/install12
l---------debian/linux-status.service1
-rwxr-xr-xdebian/rules3
-rw-r--r--debian/source/format1
10 files changed, 111 insertions, 0 deletions
diff --git a/debian/.gitignore b/debian/.gitignore
new file mode 100644
index 0000000..96bfb9e
--- /dev/null
+++ b/debian/.gitignore
@@ -0,0 +1 @@
+build-area/
diff --git a/debian/Makefile b/debian/Makefile
new file mode 100644
index 0000000..74a8a18
--- /dev/null
+++ b/debian/Makefile
@@ -0,0 +1,28 @@
+MAKEFLAGS += --warn-undefined-variables
+.DEFAULT_GOAL := all
+.DELETE_ON_ERROR:
+.SUFFIXES:
+SHELL := bash
+.SHELLFLAGS := -e -o pipefail -c
+
+escape = $(subst ','\'',$(1))
+
+makefile_dir := $(dir $(realpath $(firstword $(MAKEFILE_LIST))))
+repo_dir := $(makefile_dir)/..
+build_area_dir := $(makefile_dir)/build-area
+
+.PHONY: build/src
+build/src:
+ pushd '$(call escape,$(repo_dir))' && gbp buildpackage -S
+
+.PHONY: build/bin
+build/bin:
+ pushd '$(call escape,$(repo_dir))' && gbp buildpackage
+
+.PHONY: build/pbuilder
+build/pbuilder:
+ pushd '$(call escape,$(repo_dir))' && gbp buildpackage --git-pbuilder --git-dist=focal --git-arch=amd64
+
+.PHONY: clean
+clean:
+ rm -rf -- '$(call escape,$(build_area_dir))'
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..0d3f42f
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+linux-status (0.0.1-1) unstable; urgency=medium
+
+ * Initial release.
+
+ -- Egor Tensin <Egor.Tensin@gmail.com> Sat, 06 Mar 2021 19:48:48 +0000
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..65e93e3
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,14 @@
+Source: linux-status
+Section: admin
+Priority: optional
+Maintainer: Egor Tensin <Egor.Tensin@gmail.com>
+Build-Depends: debhelper-compat (= 12)
+Standards-Version: 4.4.1
+Homepage: https://github.com/egor-tensin/linux-status
+
+Package: linux-status
+Architecture: all
+Depends: python3, ${misc:Depends}
+Description: Simple Linux status web page
+ A simple web app to display your `top`, systemd units & timers, allow you to
+ reboot, etc.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..334eed6
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,39 @@
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: linux-status
+Upstream-Contact: Egor Tensin <Egor.Tensin@gmail.com>
+Source: https://github.com/egor-tensin/linux-status
+
+Files: *
+Copyright: 2018-2021 Egor Tensin <Egor.Tensin@gmail.com>
+License: MIT
+
+Files: debian/*
+Copyright: 2021 Egor Tensin <Egor.Tensin@gmail.com>
+License: MIT
+
+Files: css/bootstrap.min.css js/bootstrap.bundle.min.js
+Copyright: 2011-2018 The Bootstrap Authors
+License: MIT
+
+Files: js/jquery-3.3.1.min.js
+Copyright: JS Foundation and other contributors
+License: MIT
+
+License: MIT
+ Permission is hereby granted, free of charge, to any person obtaining a
+ copy of this software and associated documentation files (the "Software"),
+ to deal in the Software without restriction, including without limitation
+ the rights to use, copy, modify, merge, publish, distribute, sublicense,
+ and/or sell copies of the Software, and to permit persons to whom the
+ Software is furnished to do so, subject to the following conditions:
+ .
+ The above copyright notice and this permission notice shall be included
+ in all copies or substantial portions of the Software.
+ .
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
+ OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+ MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+ IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+ CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
+ TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
+ SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/debian/gbp.conf b/debian/gbp.conf
new file mode 100644
index 0000000..51b688e
--- /dev/null
+++ b/debian/gbp.conf
@@ -0,0 +1,7 @@
+[DEFAULT]
+upstream-tag = v%(version)s
+debian-branch = debian
+debian-tag = debian/v%(version)s
+pristine-tar = False
+export-dir = debian/build-area/
+builder = debuild -i -I -k3B3EF1235420917E0DB0723991D679FB92B036CB
diff --git a/debian/install b/debian/install
new file mode 100644
index 0000000..31d5cd4
--- /dev/null
+++ b/debian/install
@@ -0,0 +1,12 @@
+LICENSE.txt usr/share/linux-status
+
+README.md usr/share/doc/linux-status
+img/example.png usr/share/doc/linux-status/img
+
+app.py srv/linux-status
+server.py srv/linux-status
+
+index.html srv/linux-status
+css/bootstrap.min.css srv/linux-status/css
+js/bootstrap.bundle.min.js srv/linux-status/js
+js/jquery-3.3.1.min.js srv/linux-status/js
diff --git a/debian/linux-status.service b/debian/linux-status.service
new file mode 120000
index 0000000..e104dba
--- /dev/null
+++ b/debian/linux-status.service
@@ -0,0 +1 @@
+../dist/systemd/linux-status.service \ No newline at end of file
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..cbe925d
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,3 @@
+#!/usr/bin/make -f
+%:
+ dh $@
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)