aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2019-12-10 06:06:00 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2019-12-10 06:08:46 +0300
commitfe3632e107c3def98324c3a5c0c4f8d36e01a979 (patch)
tree057e0367b981ffe367603fc150259e21d37e2900 /CMakeLists.txt
parentclean up build warnings (diff)
downloadmath-server-fe3632e107c3def98324c3a5c0c4f8d36e01a979.tar.gz
math-server-fe3632e107c3def98324c3a5c0c4f8d36e01a979.zip
AppVeyor: Release builds only on master
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d8717ff..c4ef536 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,6 +14,10 @@ if(MSVC_VERSION GREATER_EQUAL "1910" AND MSVC_VERSION LESS "1920")
add_definitions(/D_SILENCE_CXX17_ALLOCATOR_VOID_DEPRECATION_WARNING)
endif()
+# AppVeyor builds complain about _WIN32_WINNT not being defined.
+# Not sure what's the right thing to do about it, arbitrarily setting it to
+# target Windows 7 as described here:
+# https://docs.microsoft.com/en-gb/windows/win32/winprog/using-the-windows-headers
if(WIN32)
add_definitions(/DNTDDI_VERSION=NTDDI_WIN7 /D_WIN32_WINNT=_WIN32_WINNT_WIN7)
endif()