aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/client/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2019-12-21 15:56:25 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2019-12-21 17:13:43 +0300
commit1a4540d78b931a11d5aece6b946ede86cf9876dc (patch)
treebab07d1c6b68d7aeb19e9e37ce8597f397961413 /client/CMakeLists.txt
parentcmake: install() PDB files (diff)
downloadmath-server-1a4540d78b931a11d5aece6b946ede86cf9876dc.tar.gz
math-server-1a4540d78b931a11d5aece6b946ede86cf9876dc.zip
cmake: use Boost::* targets
Diffstat (limited to '')
-rw-r--r--client/CMakeLists.txt9
1 files changed, 2 insertions, 7 deletions
diff --git a/client/CMakeLists.txt b/client/CMakeLists.txt
index 8455f3b..0a7937b 100644
--- a/client/CMakeLists.txt
+++ b/client/CMakeLists.txt
@@ -1,16 +1,11 @@
find_package(Boost REQUIRED COMPONENTS filesystem program_options)
-add_executable(client main.cpp)
-
-target_include_directories(client SYSTEM PRIVATE ${Boost_INCLUDE_DIRS})
-target_link_libraries(client PRIVATE ${Boost_LIBRARIES})
-target_compile_definitions(client PRIVATE BOOST_DATE_TIME_NO_LIB BOOST_REGEX_NO_LIB)
-
set(CMAKE_THREAD_PREFER_PTHREAD ON)
set(THREADS_PREFER_PTHREAD_FLAG ON)
find_package(Threads REQUIRED)
-target_link_libraries(client PRIVATE Threads::Threads)
+add_executable(client main.cpp)
+target_link_libraries(client PRIVATE Boost::disable_autolinking Boost::filesystem Boost::program_options Threads::Threads)
set_target_properties(client PROPERTIES OUTPUT_NAME math-client)
install(TARGETS client RUNTIME DESTINATION bin)