aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/server/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2019-12-07 03:36:21 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2019-12-07 03:36:21 +0300
commit00863566ec4601c65c435b74e575d49546a1c707 (patch)
tree479a0a6e96aba8191c7a65ea9bee2f4d5e3a4aba /server/CMakeLists.txt
parentadd stress_test.py (diff)
downloadmath-server-00863566ec4601c65c435b74e575d49546a1c707.tar.gz
math-server-00863566ec4601c65c435b74e575d49546a1c707.zip
split server into multiple components
In a vague attempt to make header files more readable, split server/ into a number of components. Also, refactor the unit tests to use the "Data-driven test cases" of Boost.Test.
Diffstat (limited to 'server/CMakeLists.txt')
-rw-r--r--server/CMakeLists.txt15
1 files changed, 4 insertions, 11 deletions
diff --git a/server/CMakeLists.txt b/server/CMakeLists.txt
index 7bf356a..4339da2 100644
--- a/server/CMakeLists.txt
+++ b/server/CMakeLists.txt
@@ -1,11 +1,4 @@
-find_package(Boost REQUIRED COMPONENTS filesystem program_options)
-
-option(DEBUG_ASIO "enable debug output for Boost.Asio" OFF)
-
-add_executable(server main.cpp server.cpp session.cpp session_manager.cpp)
-target_include_directories(server SYSTEM PRIVATE ${Boost_INCLUDE_DIRS})
-target_link_libraries(server PRIVATE ${Boost_LIBRARIES})
-
-if(DEBUG_ASIO)
- target_compile_definitions(server PRIVATE BOOST_ASIO_ENABLE_HANDLER_TRACKING)
-endif()
+add_subdirectory(common)
+add_subdirectory(lexer)
+add_subdirectory(parser)
+add_subdirectory(main)