aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/server/common/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2019-12-07 03:36:21 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2019-12-07 03:36:21 +0300
commit00863566ec4601c65c435b74e575d49546a1c707 (patch)
tree479a0a6e96aba8191c7a65ea9bee2f4d5e3a4aba /server/common/CMakeLists.txt
parentadd stress_test.py (diff)
downloadmath-server-00863566ec4601c65c435b74e575d49546a1c707.tar.gz
math-server-00863566ec4601c65c435b74e575d49546a1c707.zip
split server into multiple components
In a vague attempt to make header files more readable, split server/ into a number of components. Also, refactor the unit tests to use the "Data-driven test cases" of Boost.Test.
Diffstat (limited to 'server/common/CMakeLists.txt')
-rw-r--r--server/common/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/server/common/CMakeLists.txt b/server/common/CMakeLists.txt
new file mode 100644
index 0000000..5655861
--- /dev/null
+++ b/server/common/CMakeLists.txt
@@ -0,0 +1,6 @@
+find_package(Boost REQUIRED)
+
+add_library(common INTERFACE)
+
+target_include_directories(common SYSTEM INTERFACE ${Boost_INCLUDE_DIRS})
+target_link_libraries(common INTERFACE ${Boost_LIBRARIES})