aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/server/lexer/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2021-04-07 00:26:56 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2021-04-07 00:36:07 +0300
commitf1d749e3cd3aaa5ec875ea29ca010b73d3174f2c (patch)
treed0231b9283ea744223964d2f9d4e994dd165d96e /server/lexer/CMakeLists.txt
parentcmake: check CTest tests output (diff)
downloadmath-server-f1d749e3cd3aaa5ec875ea29ca010b73d3174f2c.tar.gz
math-server-f1d749e3cd3aaa5ec875ea29ca010b73d3174f2c.zip
cmake: slight CMakeLists.txt refactoring
Diffstat (limited to 'server/lexer/CMakeLists.txt')
-rw-r--r--server/lexer/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/server/lexer/CMakeLists.txt b/server/lexer/CMakeLists.txt
index 68914d9..1f053a6 100644
--- a/server/lexer/CMakeLists.txt
+++ b/server/lexer/CMakeLists.txt
@@ -1,8 +1,7 @@
+find_package(Boost REQUIRED COMPONENTS regex)
+
file(GLOB_RECURSE lexer_src "*.cpp" "*.hpp")
add_library(lexer ${lexer_src})
target_include_directories(lexer PUBLIC ..)
-
target_link_libraries(lexer PUBLIC common)
-
-find_package(Boost REQUIRED COMPONENTS regex)
target_link_libraries(lexer PRIVATE Boost::disable_autolinking Boost::regex)