aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/server/main/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2019-12-09 08:50:34 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2019-12-09 09:21:31 +0300
commit8706fa3939a82975f6e627900f52680de2ddbb49 (patch)
tree8741b1f2af1df0403ce66a842074866f06a613d8 /server/main/CMakeLists.txt
parentupdate cmake-common (diff)
downloadmath-server-8706fa3939a82975f6e627900f52680de2ddbb49.tar.gz
math-server-8706fa3939a82975f6e627900f52680de2ddbb49.zip
use CMake's install() for predictable paths
This will allow to merge the scripts for the two CIs in the future, hopefully.
Diffstat (limited to '')
-rw-r--r--server/main/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/server/main/CMakeLists.txt b/server/main/CMakeLists.txt
index e8df7cb..eefb969 100644
--- a/server/main/CMakeLists.txt
+++ b/server/main/CMakeLists.txt
@@ -12,3 +12,5 @@ target_compile_definitions(server PRIVATE BOOST_DATE_TIME_NO_LIB BOOST_REGEX_NO_
if(DEBUG_ASIO)
target_compile_definitions(server PRIVATE BOOST_ASIO_ENABLE_HANDLER_TRACKING)
endif()
+
+install(TARGETS server RUNTIME DESTINATION bin)