aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..0d02300
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,11 @@
+project(math_server CXX)
+
+option(ENABLE_TESTS "build the tests")
+
+include(common.cmake)
+
+add_subdirectory(client)
+add_subdirectory(server)
+if(ENABLE_TESTS)
+ add_subdirectory(test)
+endif()