aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e20d3d1..d8717ff 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,6 +9,20 @@ set(CC_CXX_STANDARD 17)
include(cmake/common.cmake)
+# AppVeyor builds w/ Visual Studio 2017 bombard me with stupid warnings otherwise:
+if(MSVC_VERSION GREATER_EQUAL "1910" AND MSVC_VERSION LESS "1920")
+ add_definitions(/D_SILENCE_CXX17_ALLOCATOR_VOID_DEPRECATION_WARNING)
+endif()
+
+if(WIN32)
+ add_definitions(/DNTDDI_VERSION=NTDDI_WIN7 /D_WIN32_WINNT=_WIN32_WINNT_WIN7)
+endif()
+
+# Silence deprecation warnings in Boost.Asio:
+if(WIN32)
+ add_definitions(/D_WINSOCK_DEPRECATED_NO_WARNINGS)
+endif()
+
add_subdirectory(client)
add_subdirectory(server)