aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/client/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'client/CMakeLists.txt')
-rw-r--r--client/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/client/CMakeLists.txt b/client/CMakeLists.txt
new file mode 100644
index 0000000..cd23de8
--- /dev/null
+++ b/client/CMakeLists.txt
@@ -0,0 +1,5 @@
+find_package(Boost REQUIRED COMPONENTS filesystem program_options)
+
+add_executable(client main.cpp)
+target_include_directories(client SYSTEM PRIVATE ${Boost_INCLUDE_DIRS})
+target_link_libraries(client PRIVATE ${Boost_LIBRARIES})