aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/server/lexer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'server/lexer/CMakeLists.txt')
-rw-r--r--server/lexer/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/server/lexer/CMakeLists.txt b/server/lexer/CMakeLists.txt
index 64375e8..fffb5a3 100644
--- a/server/lexer/CMakeLists.txt
+++ b/server/lexer/CMakeLists.txt
@@ -1,6 +1,8 @@
file(GLOB_RECURSE lexer_cpp "*.cpp")
file(GLOB_RECURSE lexer_hpp "*.hpp")
add_library(lexer ${lexer_cpp} ${lexer_hpp})
+target_include_directories(lexer PUBLIC ..)
+
target_link_libraries(lexer PUBLIC common)
find_package(Boost REQUIRED COMPONENTS regex)