aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/server/lexer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'server/lexer/CMakeLists.txt')
-rw-r--r--server/lexer/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/server/lexer/CMakeLists.txt b/server/lexer/CMakeLists.txt
index 9c696d3..64375e8 100644
--- a/server/lexer/CMakeLists.txt
+++ b/server/lexer/CMakeLists.txt
@@ -1,5 +1,7 @@
-find_package(Boost REQUIRED COMPONENTS regex)
-
-add_library(lexer details/parse.cpp lexer.cpp token.cpp token_type.cpp)
+file(GLOB_RECURSE lexer_cpp "*.cpp")
+file(GLOB_RECURSE lexer_hpp "*.hpp")
+add_library(lexer ${lexer_cpp} ${lexer_hpp})
target_link_libraries(lexer PUBLIC common)
+
+find_package(Boost REQUIRED COMPONENTS regex)
target_link_libraries(lexer PRIVATE Boost::disable_autolinking Boost::regex)