aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2019-12-21 17:39:31 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2019-12-21 17:39:31 +0300
commit9c38cc4a16f9314ca388dc71e3e37558d7c2d2a7 (patch)
treebea8c112036f117b8dc05831211ea96c780bebe4 /CMakeLists.txt
parentupdate cmake-common (diff)
downloadprivilege-check-9c38cc4a16f9314ca388dc71e3e37558d7c2d2a7.tar.gz
privilege-check-9c38cc4a16f9314ca388dc71e3e37558d7c2d2a7.zip
cmake: install() the .PDB file
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 065571c..00ce324 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -31,4 +31,8 @@ if(MINGW)
endif()
install(TARGETS privilege_check RUNTIME DESTINATION bin)
+if(CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
+ install(FILES "$<TARGET_PDB_FILE:privilege_check>" DESTINATION bin OPTIONAL)
+endif()
+
install(FILES README.md LICENSE.txt DESTINATION share)