aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2020-10-14 03:10:23 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2020-10-14 03:10:23 +0300
commit8fe642b86c85ec45f27424108d7a5d6fae25fe25 (patch)
treed6ee95e995a2b8e4cd753f72056aa30d3cc73c8e /CMakeLists.txt
parentAppVeyor: reorder images, 2013 second (diff)
downloadwinapi-common-8fe642b86c85ec45f27424108d7a5d6fae25fe25.tar.gz
winapi-common-8fe642b86c85ec45f27424108d7a5d6fae25fe25.zip
add error-handling functions
They are almost exact copies from my pdb-repo project at https://github.com/egor-tensin/pdb-repo/tree/fa2afec5e7af45e7f1440b2d32c2a4e63dad6a62 I'm currently thinking about renaming it to winapi-debug BTW.
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt14
1 files changed, 10 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4ffa5a5..d1f8a37 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,12 +4,18 @@ project(winapi_common CXX)
include(cmake/common.cmake)
-find_package(Boost REQUIRED)
+file(GLOB_RECURSE winapi_common_include "include/*.hpp")
+file(GLOB winapi_common_src "src/*.cpp")
+add_library(winapi_common ${winapi_common_include} ${winapi_common_src})
+target_include_directories(winapi_common PUBLIC include/)
+
+add_subdirectory(3rdparty/winapi/utf8)
+target_link_libraries(winapi_common PRIVATE winapi_utf8)
-add_library(winapi_common INTERFACE)
-target_include_directories(winapi_common INTERFACE include/)
-target_link_libraries(winapi_common INTERFACE Boost::disable_autolinking Boost::boost)
+find_package(Boost REQUIRED)
+target_link_libraries(winapi_common PUBLIC Boost::boost)
+install(TARGETS winapi_common ARCHIVE DESTINATION lib)
install(DIRECTORY include/winapi DESTINATION include)
if(WINAPI_COMMON_TESTS)