aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2020-10-15 01:15:40 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2020-10-15 01:21:31 +0300
commit735a762860b9d998dd3f5f8a62146ec7d89e5fd9 (patch)
tree574fd76f2c712bffc73ed5f1d404313ae2161e1d /test/CMakeLists.txt
parenttest/ -> test/unit_tests/ (diff)
downloadwinapi-common-735a762860b9d998dd3f5f8a62146ec7d89e5fd9.tar.gz
winapi-common-735a762860b9d998dd3f5f8a62146ec7d89e5fd9.zip
test: add test utility "args"
Diffstat (limited to '')
-rw-r--r--test/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index bed23ce..a46bf49 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -1 +1,9 @@
+add_executable(args args.cpp)
+set_target_properties(args PROPERTIES OUTPUT_NAME winapi-common-test-args)
+
+install(TARGETS args RUNTIME DESTINATION bin)
+if(CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
+ install(FILES "$<TARGET_PDB_FILE:args>" DESTINATION bin OPTIONAL)
+endif()
+
add_subdirectory(unit_tests)