aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2020-10-14 19:53:16 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2020-10-14 19:54:16 +0300
commitafd308c7b69eb1f8eb947616f953cb143f5f2126 (patch)
treea1504bbdf84515d91381124d88e248518e6ca78b /test/CMakeLists.txt
parentcmd_line.hpp: rework for this project (diff)
downloadwinapi-common-afd308c7b69eb1f8eb947616f953cb143f5f2126.tar.gz
winapi-common-afd308c7b69eb1f8eb947616f953cb143f5f2126.zip
cmake: GLOB source files
Diffstat (limited to '')
-rw-r--r--test/CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 55cdf34..33a6101 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -1,10 +1,11 @@
-find_package(Boost REQUIRED COMPONENTS unit_test_framework)
-
-add_executable(unit_tests main.cpp cmd_line.cpp error.cpp handle.cpp)
+file(GLOB unit_tests_src "*.cpp")
+add_executable(unit_tests ${unit_tests_src})
target_link_libraries(unit_tests PRIVATE winapi_common)
-target_link_libraries(unit_tests PRIVATE Boost::disable_autolinking Boost::unit_test_framework)
set_target_properties(unit_tests PROPERTIES OUTPUT_NAME winapi-common-unit-tests)
+find_package(Boost REQUIRED COMPONENTS unit_test_framework)
+target_link_libraries(unit_tests PRIVATE Boost::disable_autolinking Boost::unit_test_framework)
+
install(TARGETS unit_tests RUNTIME DESTINATION bin)
if(CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
install(FILES "$<TARGET_PDB_FILE:unit_tests>" DESTINATION bin OPTIONAL)