aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2020-10-14 03:10:23 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2020-10-14 03:10:23 +0300
commit8fe642b86c85ec45f27424108d7a5d6fae25fe25 (patch)
treed6ee95e995a2b8e4cd753f72056aa30d3cc73c8e /test/CMakeLists.txt
parentAppVeyor: reorder images, 2013 second (diff)
downloadwinapi-common-8fe642b86c85ec45f27424108d7a5d6fae25fe25.tar.gz
winapi-common-8fe642b86c85ec45f27424108d7a5d6fae25fe25.zip
add error-handling functions
They are almost exact copies from my pdb-repo project at https://github.com/egor-tensin/pdb-repo/tree/fa2afec5e7af45e7f1440b2d32c2a4e63dad6a62 I'm currently thinking about renaming it to winapi-debug BTW.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 3c23426..4c09bcd 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -1,6 +1,6 @@
find_package(Boost REQUIRED COMPONENTS unit_test_framework)
-add_executable(unit_tests main.cpp handle.cpp)
+add_executable(unit_tests main.cpp error.cpp handle.cpp)
target_link_libraries(unit_tests PRIVATE winapi_common)
target_link_libraries(unit_tests PRIVATE Boost::disable_autolinking Boost::unit_test_framework)
set_target_properties(unit_tests PROPERTIES OUTPUT_NAME winapi-common-unit-tests)