aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 10 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4ffa5a5..d1f8a37 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,12 +4,18 @@ project(winapi_common CXX)
include(cmake/common.cmake)
-find_package(Boost REQUIRED)
+file(GLOB_RECURSE winapi_common_include "include/*.hpp")
+file(GLOB winapi_common_src "src/*.cpp")
+add_library(winapi_common ${winapi_common_include} ${winapi_common_src})
+target_include_directories(winapi_common PUBLIC include/)
+
+add_subdirectory(3rdparty/winapi/utf8)
+target_link_libraries(winapi_common PRIVATE winapi_utf8)
-add_library(winapi_common INTERFACE)
-target_include_directories(winapi_common INTERFACE include/)
-target_link_libraries(winapi_common INTERFACE Boost::disable_autolinking Boost::boost)
+find_package(Boost REQUIRED)
+target_link_libraries(winapi_common PUBLIC Boost::boost)
+install(TARGETS winapi_common ARCHIVE DESTINATION lib)
install(DIRECTORY include/winapi DESTINATION include)
if(WINAPI_COMMON_TESTS)