aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt13
1 files changed, 1 insertions, 12 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 33a6101..bed23ce 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -1,12 +1 @@
-file(GLOB unit_tests_src "*.cpp")
-add_executable(unit_tests ${unit_tests_src})
-target_link_libraries(unit_tests PRIVATE winapi_common)
-set_target_properties(unit_tests PROPERTIES OUTPUT_NAME winapi-common-unit-tests)
-
-find_package(Boost REQUIRED COMPONENTS unit_test_framework)
-target_link_libraries(unit_tests PRIVATE Boost::disable_autolinking Boost::unit_test_framework)
-
-install(TARGETS unit_tests RUNTIME DESTINATION bin)
-if(CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
- install(FILES "$<TARGET_PDB_FILE:unit_tests>" DESTINATION bin OPTIONAL)
-endif()
+add_subdirectory(unit_tests)