aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2021-05-15 23:36:29 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2021-05-15 23:36:29 +0300
commit46ef2fbd49b2e48206a0554ae9a7d84f5961d817 (patch)
treed25e78e4c7e8a36c960a1157e06be77d39a0afcf /CMakeLists.txt
parentrename the project (diff)
downloadwinapi-debug-46ef2fbd49b2e48206a0554ae9a7d84f5961d817.tar.gz
winapi-debug-46ef2fbd49b2e48206a0554ae9a7d84f5961d817.zip
use error reporting from winapi-common
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 20e528a..081e8e2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -27,14 +27,14 @@ endif()
include(cmake/common.cmake)
find_package(Boost REQUIRED)
-add_subdirectory(3rdparty/winapi/utf8)
+add_subdirectory(3rdparty/winapi/common)
file(GLOB_RECURSE winapi_debug_include "include/*.hpp")
file(GLOB_RECURSE winapi_debug_src "src/*.cpp")
add_library(winapi_debug ${winapi_debug_include} ${winapi_debug_src})
target_compile_definitions(winapi_debug PUBLIC _NO_CVCONST_H)
target_include_directories(winapi_debug PUBLIC include/)
-target_link_libraries(winapi_debug PRIVATE winapi_utf8)
+target_link_libraries(winapi_debug PRIVATE winapi_common winapi_utf8)
target_link_libraries(winapi_debug
PUBLIC Boost::boost
PRIVATE Boost::disable_autolinking)