aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2020-01-15 01:06:50 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2020-01-15 02:01:44 +0300
commit54619b8571c6c677d98cbe2756271287197feea8 (patch)
tree462ff1ef286d4f46e528125cc02fb447e54f66ee /CMakeLists.txt
parentmingw builds: get rid of #pragma warning (diff)
downloadwinapi-debug-54619b8571c6c677d98cbe2756271287197feea8.tar.gz
winapi-debug-54619b8571c6c677d98cbe2756271287197feea8.zip
silence DbgHelp warnings on VS 2015
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c531127..ef02ccf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,6 +22,11 @@ if(MINGW)
_WIN32_WINNT=_WIN32_WINNT_WIN8)
endif()
+if(MSVC_VERSION EQUAL 1900)
+ # DbgHelp warnings on Visual Studio 2015:
+ target_compile_options(pdb_repo PUBLIC /wd4091)
+endif()
+
add_subdirectory(utils)
install(FILES LICENSE.txt DESTINATION share)