aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2020-01-15 03:17:04 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2020-01-15 03:20:15 +0300
commit15a9dd50ae2112d6fe80b833bd05278a9b4f67a7 (patch)
tree2b67329c34a63071517b1a1fc7abb96756e179bc /test/CMakeLists.txt
parentmingw builds: external definitions for static members (diff)
downloadwinapi-debug-15a9dd50ae2112d6fe80b833bd05278a9b4f67a7.tar.gz
winapi-debug-15a9dd50ae2112d6fe80b833bd05278a9b4f67a7.zip
add test/ to test, for starters, enum_symbols
Diffstat (limited to '')
-rw-r--r--test/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
new file mode 100644
index 0000000..0cd4c1a
--- /dev/null
+++ b/test/CMakeLists.txt
@@ -0,0 +1,6 @@
+add_executable(lab_rat lab_rat.cpp)
+
+install(TARGETS lab_rat RUNTIME DESTINATION bin)
+if(CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
+ install(FILES "$<TARGET_PDB_FILE:lab_rat>" DESTINATION bin OPTIONAL)
+endif()