aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/test/unit_tests/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2021-03-24 22:33:30 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2021-03-24 22:40:54 +0300
commita4eb193ea2d05ad6af821013c9bea17068773542 (patch)
tree1dd163549accf00c4c49489358d637bf21ed0935 /test/unit_tests/CMakeLists.txt
parentadd CTest tests (diff)
downloadwinapi-debug-a4eb193ea2d05ad6af821013c9bea17068773542.tar.gz
winapi-debug-a4eb193ea2d05ad6af821013c9bea17068773542.zip
unit_tests: dynamic path to test_lib.pdb
Diffstat (limited to 'test/unit_tests/CMakeLists.txt')
-rw-r--r--test/unit_tests/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/test/unit_tests/CMakeLists.txt b/test/unit_tests/CMakeLists.txt
index 90f8bed..ae43fbb 100644
--- a/test/unit_tests/CMakeLists.txt
+++ b/test/unit_tests/CMakeLists.txt
@@ -9,4 +9,10 @@ if(CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
install(FILES "$<TARGET_PDB_FILE:unit_tests>" DESTINATION bin/test OPTIONAL)
endif()
-add_test(NAME unit_tests COMMAND unit_tests --log_level=all --no_color_output)
+if(MSVC)
+ # Set the working directory so that the unit_tests binary can find the
+ # test_lib shared library binary.
+ add_test(NAME unit_tests
+ COMMAND unit_tests --log_level=all --no_color_output -- --test_lib_pdb "$<TARGET_PDB_FILE:test_lib>"
+ WORKING_DIRECTORY "$<TARGET_FILE_DIR:test_lib>")
+endif()