aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/utils/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2020-09-14 15:42:33 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2020-09-14 15:44:13 +0300
commit23af3512d2ea792eb9274eab5c15369aa8fb9d9d (patch)
tree4c3826669bad5009a96742a692a3d6253ea20d2b /utils/CMakeLists.txt
parentDbgHelp: fix move ctor (diff)
downloadwinapi-debug-23af3512d2ea792eb9274eab5c15369aa8fb9d9d.tar.gz
winapi-debug-23af3512d2ea792eb9274eab5c15369aa8fb9d9d.zip
disable Boost autolinking feature
Diffstat (limited to '')
-rw-r--r--utils/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/utils/CMakeLists.txt b/utils/CMakeLists.txt
index a34d72a..f724654 100644
--- a/utils/CMakeLists.txt
+++ b/utils/CMakeLists.txt
@@ -3,7 +3,7 @@ find_package(Boost REQUIRED COMPONENTS filesystem program_options)
function(add_util name src)
add_executable("${name}" ${src})
target_link_libraries("${name}" PRIVATE pdb_repo)
- target_link_libraries("${name}" PRIVATE Boost::filesystem Boost::nowide Boost::program_options)
+ target_link_libraries("${name}" PRIVATE Boost::disable_autolinking Boost::filesystem Boost::nowide Boost::program_options)
install(TARGETS "${name}" RUNTIME DESTINATION bin)
if(CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
install(FILES "$<TARGET_PDB_FILE:${name}>" DESTINATION bin OPTIONAL)