aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2020-10-13 16:47:56 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2020-10-13 16:59:21 +0300
commita53523162f6f09d1297780d04679790f35509361 (patch)
tree6a1e85873d1682aa04bb95a2c094cc0796fb5d05 /CMakeLists.txt
parentREADME: add Travis badge (diff)
downloadwinapi-utf8-a53523162f6f09d1297780d04679790f35509361.tar.gz
winapi-utf8-a53523162f6f09d1297780d04679790f35509361.zip
use SafeInt
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5588dd6..c868a3b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,10 +4,13 @@ project(winapi_utf8 CXX)
include(cmake/common.cmake)
+add_subdirectory(3rdparty/microsoft/SafeInt)
+
file(GLOB_RECURSE winapi_utf8_include "include/*.hpp")
file(GLOB winapi_utf8_src "src/*.cpp")
add_library(winapi_utf8 ${winapi_utf8_include} ${winapi_utf8_src})
target_include_directories(winapi_utf8 PUBLIC include/)
+target_link_libraries(winapi_utf8 PRIVATE SafeInt)
# Vista is the lower bound (due to WC_ERR_INVALID_CHARS):
if(MINGW)