aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2020-10-04 10:50:19 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2020-10-04 10:50:19 +0300
commite3fc06afd790b0fab3d31e6a81d75ccc0d7bb1e9 (patch)
tree4189a9241f7463a2bd51c16071a878f5319a18e3 /CMakeLists.txt
parentinitial commit (diff)
downloadwinapi-utf8-e3fc06afd790b0fab3d31e6a81d75ccc0d7bb1e9.tar.gz
winapi-utf8-e3fc06afd790b0fab3d31e6a81d75ccc0d7bb1e9.zip
add string conversion functions + some tests
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..d43a1aa
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,17 @@
+cmake_minimum_required(VERSION 3.5) # for Boost::* imported targets
+
+project(winapi_utf8 CXX)
+
+include(cmake/common.cmake)
+
+file(GLOB_RECURSE winapi_utf8_include "include/*.hpp")
+file(GLOB winapi_utf8_src "src/*.cpp")
+add_library(winapi_utf8 ${winapi_utf8_include} ${winapi_utf8_src})
+target_include_directories(winapi_utf8 PUBLIC include/)
+install(TARGETS winapi_utf8 LIBRARY DESTINATION lib)
+
+if(WINAPI_UTF8_ENABLE_TESTS)
+ add_subdirectory(test)
+endif()
+
+install(FILES LICENSE.txt DESTINATION share)