aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2021-05-04 14:38:09 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2021-05-04 15:01:05 +0300
commit721ca6fc423e85f8c1ecc93740b3ed044fc65c21 (patch)
tree457577a9701b2cf64a591f9ca6ef4d6c4daf5e50 /CMakeLists.txt
parentworkflows/ci: linting (diff)
downloadwinapi-utf8-721ca6fc423e85f8c1ecc93740b3ed044fc65c21.tar.gz
winapi-utf8-721ca6fc423e85f8c1ecc93740b3ed044fc65c21.zip
get rid of SafeInt
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 0 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d2e111a..b4b277b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -5,15 +5,10 @@ enable_testing()
include(cmake/common.cmake)
-if(NOT TARGET SafeInt)
- add_subdirectory(3rdparty/microsoft/SafeInt EXCLUDE_FROM_ALL)
-endif()
-
file(GLOB_RECURSE winapi_utf8_include "include/*.hpp")
file(GLOB winapi_utf8_src "src/*.cpp")
add_library(winapi_utf8 ${winapi_utf8_include} ${winapi_utf8_src})
target_include_directories(winapi_utf8 PUBLIC include)
-target_link_libraries(winapi_utf8 PRIVATE SafeInt)
# Vista is the lower bound (due to WC_ERR_INVALID_CHARS):
if(MINGW)
target_compile_definitions(winapi_utf8 PRIVATE