aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2020-10-04 10:50:19 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2020-10-04 10:50:19 +0300
commite3fc06afd790b0fab3d31e6a81d75ccc0d7bb1e9 (patch)
tree4189a9241f7463a2bd51c16071a878f5319a18e3 /test/CMakeLists.txt
parentinitial commit (diff)
downloadwinapi-utf8-e3fc06afd790b0fab3d31e6a81d75ccc0d7bb1e9.tar.gz
winapi-utf8-e3fc06afd790b0fab3d31e6a81d75ccc0d7bb1e9.zip
add string conversion functions + some tests
Diffstat (limited to '')
-rw-r--r--test/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
new file mode 100644
index 0000000..8fc1dee
--- /dev/null
+++ b/test/CMakeLists.txt
@@ -0,0 +1,10 @@
+find_package(Boost REQUIRED COMPONENTS unit_test_framework)
+
+add_executable(unit_tests main.cpp convert.cpp string.cpp)
+target_link_libraries(unit_tests PRIVATE winapi_utf8)
+target_link_libraries(unit_tests PRIVATE Boost::disable_autolinking Boost::unit_test_framework)
+
+install(TARGETS unit_tests RUNTIME DESTINATION bin/test)
+if(CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
+ install(FILES "$<TARGET_PDB_FILE:unit_tests>" DESTINATION bin/test OPTIONAL)
+endif()