aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..d43a1aa
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,17 @@
+cmake_minimum_required(VERSION 3.5) # for Boost::* imported targets
+
+project(winapi_utf8 CXX)
+
+include(cmake/common.cmake)
+
+file(GLOB_RECURSE winapi_utf8_include "include/*.hpp")
+file(GLOB winapi_utf8_src "src/*.cpp")
+add_library(winapi_utf8 ${winapi_utf8_include} ${winapi_utf8_src})
+target_include_directories(winapi_utf8 PUBLIC include/)
+install(TARGETS winapi_utf8 LIBRARY DESTINATION lib)
+
+if(WINAPI_UTF8_ENABLE_TESTS)
+ add_subdirectory(test)
+endif()
+
+install(FILES LICENSE.txt DESTINATION share)