aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--test/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 8fc1dee..f0c6f85 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -3,8 +3,9 @@ find_package(Boost REQUIRED COMPONENTS unit_test_framework)
add_executable(unit_tests main.cpp convert.cpp string.cpp)
target_link_libraries(unit_tests PRIVATE winapi_utf8)
target_link_libraries(unit_tests PRIVATE Boost::disable_autolinking Boost::unit_test_framework)
+set_target_properties(unit_tests PROPERTIES OUTPUT_NAME winapi-utf8-unit-tests)
-install(TARGETS unit_tests RUNTIME DESTINATION bin/test)
+install(TARGETS unit_tests RUNTIME DESTINATION bin)
if(CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
- install(FILES "$<TARGET_PDB_FILE:unit_tests>" DESTINATION bin/test OPTIONAL)
+ install(FILES "$<TARGET_PDB_FILE:unit_tests>" DESTINATION bin OPTIONAL)
endif()