aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--test/CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index f0c6f85..3664b3d 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -1,10 +1,11 @@
-find_package(Boost REQUIRED COMPONENTS unit_test_framework)
-
-add_executable(unit_tests main.cpp convert.cpp string.cpp)
+file(GLOB unit_tests_cpp "*.cpp")
+add_executable(unit_tests ${unit_tests_cpp})
target_link_libraries(unit_tests PRIVATE winapi_utf8)
-target_link_libraries(unit_tests PRIVATE Boost::disable_autolinking Boost::unit_test_framework)
set_target_properties(unit_tests PROPERTIES OUTPUT_NAME winapi-utf8-unit-tests)
+find_package(Boost REQUIRED COMPONENTS unit_test_framework)
+target_link_libraries(unit_tests PRIVATE Boost::disable_autolinking Boost::unit_test_framework)
+
install(TARGETS unit_tests RUNTIME DESTINATION bin)
if(CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
install(FILES "$<TARGET_PDB_FILE:unit_tests>" DESTINATION bin OPTIONAL)