aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/um/wrappers/special/nt_namespace/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--um/wrappers/special/nt_namespace/CMakeLists.txt13
1 files changed, 5 insertions, 8 deletions
diff --git a/um/wrappers/special/nt_namespace/CMakeLists.txt b/um/wrappers/special/nt_namespace/CMakeLists.txt
index ede2673..c9c6395 100644
--- a/um/wrappers/special/nt_namespace/CMakeLists.txt
+++ b/um/wrappers/special/nt_namespace/CMakeLists.txt
@@ -1,10 +1,7 @@
-project(libnt_namespace)
-file(GLOB libnt_namespace_sources "src/*.cpp")
-file(GLOB_RECURSE libnt_namespace_headers "include/*.hpp")
-add_library(libnt_namespace
- ${libnt_namespace_sources}
- ${libnt_namespace_headers})
-target_link_libraries(libnt_namespace libservice)
-target_include_directories(libnt_namespace PUBLIC include/)
+file(GLOB_RECURSE nt_namespace_include "include/*.hpp")
+file(GLOB nt_namespace_src "src/*.cpp")
+add_library(nt_namespace ${nt_namespace_src} ${nt_namespace_include})
+target_include_directories(nt_namespace PUBLIC include/)
+target_link_libraries(nt_namespace PRIVATE service)
add_subdirectory(utils)