aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/utils/libnt_path_converter/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'utils/libnt_path_converter/CMakeLists.txt')
-rw-r--r--utils/libnt_path_converter/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/utils/libnt_path_converter/CMakeLists.txt b/utils/libnt_path_converter/CMakeLists.txt
new file mode 100644
index 0000000..626a4b1
--- /dev/null
+++ b/utils/libnt_path_converter/CMakeLists.txt
@@ -0,0 +1,9 @@
+project(libnt_path_converter)
+file(GLOB ${PROJECT_NAME}_sources "src/*.cpp")
+file(GLOB_RECURSE ${PROJECT_NAME}_headers "include/*.hpp")
+add_library(${PROJECT_NAME} ${${PROJECT_NAME}_sources}
+ ${${PROJECT_NAME}_headers})
+target_link_libraries(${PROJECT_NAME} libservice)
+target_include_directories(${PROJECT_NAME} PUBLIC include/)
+
+add_subdirectory(utils)