aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2016-05-19 04:13:47 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2016-05-19 04:13:47 +0300
commitaebc96e6efc369c09a95fb641ca90935930cf19b (patch)
tree38db5723b71c13804a88e9e129f9a20807b78f4e /CMakeLists.txt
parentREADME update (diff)
downloadaes-tools-aebc96e6efc369c09a95fb641ca90935930cf19b.tar.gz
aes-tools-aebc96e6efc369c09a95fb641ca90935930cf19b.zip
rename the project
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt20
1 files changed, 10 insertions, 10 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 582309a..db1581f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,18 +1,18 @@
-project(aesni C CXX ASM_MASM)
+project(aes_tools C CXX ASM_MASM)
-file(GLOB_RECURSE libaesni_headers "include/*.h")
+file(GLOB_RECURSE libaes_headers "include/*.h")
if(AESNI_USE_ASM)
- file(GLOB libaesni_c_sources "src/*.c")
- file(GLOB libaesni_asm_sources "src/asm/*.asm")
- set(libaesni_sources ${libaesni_asm_sources} ${libaesni_c_sources})
- set_source_files_properties(${libaesni_asm_sources} PROPERTIES COMPILE_FLAGS "/safeseh")
+ file(GLOB libaes_c_sources "src/*.c")
+ file(GLOB libaes_asm_sources "src/asm/*.asm")
+ set(libaes_sources ${libaes_asm_sources} ${libaes_c_sources})
+ set_source_files_properties(${libaes_asm_sources} PROPERTIES COMPILE_FLAGS "/safeseh")
# Setting CMAKE_ASM_MASM_FLAGS doesn't work: http://www.cmake.org/Bug/view.php?id=14711
else()
- file(GLOB_RECURSE libaesni_sources "src/*.c")
+ file(GLOB_RECURSE libaes_sources "src/*.c")
endif()
-add_library(libaesni ${libaesni_sources} ${libaesni_headers})
-target_include_directories(libaesni PUBLIC include/)
-target_compile_definitions(libaesni PRIVATE _CRT_SECURE_NO_WARNINGS)
+add_library(libaes ${libaes_sources} ${libaes_headers})
+target_include_directories(libaes PUBLIC include/)
+target_compile_definitions(libaes PRIVATE _CRT_SECURE_NO_WARNINGS)
add_subdirectory(cxx)