aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2019-12-21 12:48:48 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2019-12-21 12:48:48 +0300
commitd03d853b9a608dda5ef9cbb40384f3dbabb3ed5a (patch)
tree71bb2b05c0ff8159d387116ef5dcf50075981c6d /CMakeLists.txt
parentupdate cmake-common (diff)
downloadaes-tools-d03d853b9a608dda5ef9cbb40384f3dbabb3ed5a.tar.gz
aes-tools-d03d853b9a608dda5ef9cbb40384f3dbabb3ed5a.zip
cmake: use Boost::* imported targets
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 56b32a7..d030045 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,4 @@
-cmake_minimum_required(VERSION 3.1)
+cmake_minimum_required(VERSION 3.5) # for Boost::* imported targets
project(aes_tools C CXX)
@@ -31,7 +31,6 @@ if(CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMPILER_IS_GNUCXX)
endif()
add_subdirectory(cxx)
-
add_subdirectory(utils)
install(FILES LICENSE.txt DESTINATION share)