aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/utils/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2015-12-28 03:26:46 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2015-12-28 03:26:46 +0300
commit6fe0f155b0a0daa5affe1482da50cbe152358b07 (patch)
treea305e26159bcb266c02cd8e9f9292bad839bda79 /utils/CMakeLists.txt
parentutils: refactoring (diff)
downloadaes-tools-6fe0f155b0a0daa5affe1482da50cbe152358b07.tar.gz
aes-tools-6fe0f155b0a0daa5affe1482da50cbe152358b07.zip
utils: interface update & refactoring
Diffstat (limited to 'utils/CMakeLists.txt')
-rw-r--r--utils/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/utils/CMakeLists.txt b/utils/CMakeLists.txt
index 97ecfb6..0d57e27 100644
--- a/utils/CMakeLists.txt
+++ b/utils/CMakeLists.txt
@@ -1,11 +1,11 @@
find_package(Boost REQUIRED COMPONENTS filesystem program_options system)
-add_executable(util_encrypt_block encrypt_block.cpp block_cmd_parser.hpp block_dumper.hpp data_parsers.hpp)
+add_executable(util_encrypt_block encrypt_block.cpp block_cmd_parser.hpp block_dumper.hpp block_input.hpp data_parsers.hpp)
target_include_directories(util_encrypt_block PRIVATE ${Boost_INCLUDE_DIRS})
target_link_libraries(util_encrypt_block libaesnixx ${Boost_LIBRARIES})
set_target_properties(util_encrypt_block PROPERTIES OUTPUT_NAME encrypt_block)
-add_executable(util_decrypt_block decrypt_block.cpp block_cmd_parser.hpp block_dumper.hpp data_parsers.hpp)
+add_executable(util_decrypt_block decrypt_block.cpp block_cmd_parser.hpp block_dumper.hpp block_input.hpp data_parsers.hpp)
target_include_directories(util_decrypt_block PRIVATE ${Boost_INCLUDE_DIRS})
target_link_libraries(util_decrypt_block libaesnixx ${Boost_LIBRARIES})
set_target_properties(util_decrypt_block PROPERTIES OUTPUT_NAME decrypt_block)