aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/cxx/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'cxx/CMakeLists.txt')
-rw-r--r--cxx/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/cxx/CMakeLists.txt b/cxx/CMakeLists.txt
index 2c265f5..64613f7 100644
--- a/cxx/CMakeLists.txt
+++ b/cxx/CMakeLists.txt
@@ -2,8 +2,7 @@ find_package(Boost REQUIRED)
add_library(aesxx INTERFACE)
target_include_directories(aesxx INTERFACE include/)
-target_include_directories(aesxx SYSTEM INTERFACE ${Boost_INCLUDE_DIRS})
-target_link_libraries(aesxx INTERFACE aes)
+target_link_libraries(aesxx INTERFACE aes Boost::boost)
if(MSVC_VERSION EQUAL 1900)
# These annoying DbgHelp.h warnings: