aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt16
1 files changed, 8 insertions, 8 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 0ee556f..2d58160 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -26,12 +26,12 @@ test(aes256ctr)
find_package(Boost REQUIRED COMPONENTS program_options)
-add_executable(test_encrypt_block_aes encrypt_block_aes.cpp common_aes.hpp)
-target_include_directories(test_encrypt_block_aes PRIVATE ${Boost_INCLUDE_DIRS})
-target_link_libraries(test_encrypt_block_aes libaesni libaesnixx ${Boost_LIBRARIES})
-set_target_properties(test_encrypt_block_aes PROPERTIES OUTPUT_NAME encrypt_block_aes)
+add_executable(test_aes_encrypt_block aes_encrypt_block.cpp aes_common.hpp)
+target_include_directories(test_aes_encrypt_block PRIVATE ${Boost_INCLUDE_DIRS})
+target_link_libraries(test_aes_encrypt_block libaesni libaesnixx ${Boost_LIBRARIES})
+set_target_properties(test_aes_encrypt_block PROPERTIES OUTPUT_NAME aes_encrypt_block)
-add_executable(test_decrypt_block_aes decrypt_block_aes.cpp common_aes.hpp)
-target_include_directories(test_decrypt_block_aes PRIVATE ${Boost_INCLUDE_DIRS})
-target_link_libraries(test_decrypt_block_aes libaesni libaesnixx ${Boost_LIBRARIES})
-set_target_properties(test_decrypt_block_aes PROPERTIES OUTPUT_NAME decrypt_block_aes)
+add_executable(test_aes_decrypt_block aes_decrypt_block.cpp aes_common.hpp)
+target_include_directories(test_aes_decrypt_block PRIVATE ${Boost_INCLUDE_DIRS})
+target_link_libraries(test_aes_decrypt_block libaesni libaesnixx ${Boost_LIBRARIES})
+set_target_properties(test_aes_decrypt_block PROPERTIES OUTPUT_NAME aes_decrypt_block)