aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 2a1cc9a..4ca993e 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -23,3 +23,12 @@ test(aes256cbc)
test(aes256cfb)
test(aes256ofb)
test(aes256ctr)
+
+add_executable(test_encrypt_block_aes encrypt_block_aes.cpp)
+target_link_libraries(test_encrypt_block_aes libaesni libaesnixx)
+set_target_properties(test_encrypt_block_aes PROPERTIES OUTPUT_NAME encrypt_block_aes)
+
+add_executable(test_decrypt_block_aes decrypt_block_aes.cpp)
+target_link_libraries(test_decrypt_block_aes libaesni libaesnixx)
+set_target_properties(test_decrypt_block_aes PROPERTIES OUTPUT_NAME decrypt_block_aes)
+