aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/pyproject.toml
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2023-03-02 12:41:30 +0100
committerEgor Tensin <Egor.Tensin@gmail.com>2023-03-02 12:41:30 +0100
commit69a10662ae6c5f2cebbc5349b3b3faeca343bfc8 (patch)
tree946529165d63b1811fe80c23c85bb61021d2bd81 /pyproject.toml
parentdocker: remove entrypoint.sh (diff)
downloadcgitize-69a10662ae6c5f2cebbc5349b3b3faeca343bfc8.tar.gz
cgitize-69a10662ae6c5f2cebbc5349b3b3faeca343bfc8.zip
packaging: move to pyproject.toml-only
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml35
1 files changed, 34 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 9787c3b..0c9f7dc 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,3 +1,36 @@
[build-system]
-requires = ["setuptools", "wheel"]
+requires = ["setuptools>=61.0"]
build-backend = "setuptools.build_meta"
+
+[project]
+name = "cgitize"
+description = "Self-host your repositories using cgit"
+license = {text = "MIT"}
+version = "4.0.8"
+authors = [{name = "Egor Tensin", email = "Egor.Tensin@gmail.com"}]
+readme = "README.md"
+requires-python = ">=3.6"
+
+dependencies = [
+ "atlassian-python-api ~= 3.28.0",
+ "PyGithub ~= 1.0",
+ "python-gitlab ~= 2.0",
+ "tomli ~= 1.0",
+]
+
+classifiers = [
+ "Development Status :: 5 - Production/Stable",
+ "License :: OSI Approved :: MIT License",
+ "Programming Language :: Python :: 3",
+ "Topic :: Software Development :: Version Control :: Git",
+]
+
+[project.urls]
+"Homepage" = "https://github.com/egor-tensin/cgitize"
+"Bug Tracker" = "https://github.com/egor-tensin/cgitize/issues"
+
+[project.scripts]
+cgitize = "cgitize.main:main"
+
+[tool.setuptools.packages]
+find = {}