aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2023-05-01 17:40:33 +0200
committerEgor Tensin <Egor.Tensin@gmail.com>2023-05-06 16:24:23 +0200
commit1907a90783165d13a53f600a82cd00dbb75a10ed (patch)
tree042b999cb414d1aec9043f4b72f00e3ede84db7b /CMakeLists.txt
parentadd a cimple-valgrind executable (diff)
downloadcimple-1907a90783165d13a53f600a82cd00dbb75a10ed.tar.gz
cimple-1907a90783165d13a53f600a82cd00dbb75a10ed.zip
add a couple of the most basic tests using Pytest
I'm super-unsure about this; I don't really like all the magic, but we'll see, I guess?
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c82ef24..848890d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,6 +2,9 @@ cmake_minimum_required(VERSION 3.3) # for include-what-you-use
project(cimple VERSION 0.0.1 LANGUAGES C)
+enable_testing()
+
add_subdirectory(src)
+add_subdirectory(test)
install(FILES LICENSE.txt DESTINATION "share/doc/${PROJECT_NAME}")