aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2022-08-28 17:06:07 +0200
committerEgor Tensin <Egor.Tensin@gmail.com>2022-08-28 17:06:07 +0200
commitefb7438799af73370b0ebef46c519cf0fad3da32 (patch)
tree39608e1c6a6e374147da93395478b3cd14448066 /CMakeLists.txt
parentmake compilers happier (diff)
downloadcimple-efb7438799af73370b0ebef46c519cf0fad3da32.tar.gz
cimple-efb7438799af73370b0ebef46c519cf0fad3da32.zip
cmake: add install() rules
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..093593d
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,7 @@
+cmake_minimum_required(VERSION 3.0)
+
+project(cimple VERSION 0.0.1 LANGUAGES C)
+
+add_subdirectory(src)
+
+install(FILES LICENSE.txt DESTINATION "share/doc/${PROJECT_NAME}")