aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2022-08-22 13:40:27 +0200
committerEgor Tensin <Egor.Tensin@gmail.com>2022-08-23 21:44:04 +0200
commit1ce4acb85a3bcb953c0f9cc91d2edc855969948b (patch)
treec06abb52fef74d375c87a7bdf39e7777bbf1b3b1 /src/CMakeLists.txt
parentadd doc/rationale.md (diff)
downloadcimple-1ce4acb85a3bcb953c0f9cc91d2edc855969948b.tar.gz
cimple-1ce4acb85a3bcb953c0f9cc91d2edc855969948b.zip
add some code
A basic client-server app, the client sends commands as an array of strings. Hopefully I didn't mess up, and hopefully it'll be useful.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..61fdfa6
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,16 @@
+cmake_minimum_required(VERSION 3.0)
+
+project(tinyCI VERSION 0.0.1 LANGUAGES C)
+
+if(MSVC)
+ add_compile_options(/W4 /WX)
+else()
+ add_compile_options(-Wall -Wextra -Werror)
+endif()
+
+add_compile_definitions(_GNU_SOURCE)
+
+add_compile_definitions(VERSION="${PROJECT_VERSION}")
+
+add_executable(server server_main.c server.c cmd.c net.c)
+add_executable(client client_main.c client.c cmd.c net.c)