aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2022-08-26 05:51:53 +0200
committerEgor Tensin <Egor.Tensin@gmail.com>2022-08-26 05:54:22 +0200
commit1de2aaa4001eb2d0ddfc4f86ab2c2a3eebdc9841 (patch)
tree85b0290fd51c220a9a621e98c0b88d92ce776e33 /src/CMakeLists.txt
parentworker: capture process output (diff)
downloadcimple-1de2aaa4001eb2d0ddfc4f86ab2c2a3eebdc9841.tar.gz
cimple-1de2aaa4001eb2d0ddfc4f86ab2c2a3eebdc9841.zip
worker: allow graceful shutdowns
Well, maybe "graceful" is a strong word, but now you _can_ do ./server & ./worker & ./client ci_run URL REV && kill "$( pidof worker )" and the worker will wait for the CI run to complete.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index c2333a8..6476318 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -29,7 +29,8 @@ add_executable(worker worker_main.c worker.c
git.c
msg.c
net.c
- process.c)
+ process.c
+ signal.c)
target_link_libraries(server PRIVATE pthread)
target_link_libraries(worker PRIVATE git2 pthread)