aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2023-06-13 04:29:41 +0200
committerEgor Tensin <Egor.Tensin@gmail.com>2023-06-13 04:29:41 +0200
commit2dbd48efc249a5ad82443a62dfe767b39b688961 (patch)
treefb034bd845bb73bbb44f85b856d520937b49b1c7 /src/CMakeLists.txt
parentminor refactoring (diff)
downloadcimple-2dbd48efc249a5ad82443a62dfe767b39b688961.tar.gz
cimple-2dbd48efc249a5ad82443a62dfe767b39b688961.zip
cmake: why the hell would I need MSVC options
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index fb94b3a..b5ea527 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1,8 +1,4 @@
-if(MSVC)
- add_compile_options(/W4 /WX)
-else()
- add_compile_options(-std=c17 -Wpedantic -Wall -Wextra $<$<NOT:$<CONFIG:Debug>>:-Werror>)
-endif()
+add_compile_options(-std=c17 -Wpedantic -Wall -Wextra $<$<NOT:$<CONFIG:Debug>>:-Werror>)
# Even w/ _POSIX_C_SOURCE=200809L, we still need accept4, pipe2, execvpe, etc.,
# which are all _GNU_SOURCE-only (at least for glibc). Try compiling without