aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2023-07-18 23:23:00 +0200
committerEgor Tensin <Egor.Tensin@gmail.com>2023-07-18 23:27:41 +0200
commit11f757e9e9027ff045680b471663555ed5ff946c (patch)
tree09dbe65272b3bc54e068683afa7a6aedc821a611 /test/CMakeLists.txt
parentflame_graph.sh -> flamegraph.sh (diff)
downloadcimple-11f757e9e9027ff045680b471663555ed5ff946c.tar.gz
cimple-11f757e9e9027ff045680b471663555ed5ff946c.zip
test: store multiple flame graphs alongside
Previously, it would get stored in build/flame_graph/flame_graphs.svg. Now, the test repository codename is added to the file name. Also, some refactoring and simplifying test filtering.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index f9f53e6..edbf8aa 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -21,13 +21,13 @@ function(add_python_tests name)
endfunction()
add_python_tests(python_tests_sanity
- Python3::Interpreter -m pytest ${python_test_args} -m "not stress")
+ Python3::Interpreter -m pytest ${python_test_args} -m "not stress and not flame_graph")
add_python_tests(python_tests_stress
Python3::Interpreter -m pytest ${python_test_args} -m "stress")
add_python_tests(python_tests_valgrind
- Python3::Interpreter -m pytest ${python_test_args} -m "valgrind"
+ Python3::Interpreter -m pytest ${python_test_args} -m "not stress and not flame_graph"
--valgrind-binary "${CMAKE_CURRENT_SOURCE_DIR}/../src/valgrind.sh")
if(NOT DEFINED FLAME_GRAPHS_DIR)