aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2023-05-01 17:40:33 +0200
committerEgor Tensin <Egor.Tensin@gmail.com>2023-05-06 16:24:23 +0200
commit1907a90783165d13a53f600a82cd00dbb75a10ed (patch)
tree042b999cb414d1aec9043f4b72f00e3ede84db7b /test/CMakeLists.txt
parentadd a cimple-valgrind executable (diff)
downloadcimple-1907a90783165d13a53f600a82cd00dbb75a10ed.tar.gz
cimple-1907a90783165d13a53f600a82cd00dbb75a10ed.zip
add a couple of the most basic tests using Pytest
I'm super-unsure about this; I don't really like all the magic, but we'll see, I guess?
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
new file mode 100644
index 0000000..5d16f4e
--- /dev/null
+++ b/test/CMakeLists.txt
@@ -0,0 +1,11 @@
+find_package(Python3 REQUIRED COMPONENTS Interpreter)
+
+add_test(
+ NAME integration_tests
+ COMMAND Python3::Interpreter -m pytest
+ "${CMAKE_CURRENT_SOURCE_DIR}"
+ --server-binary "$<TARGET_FILE:server>"
+ --worker-binary "$<TARGET_FILE:worker>"
+ --client-binary "$<TARGET_FILE:client>"
+ --project-version "${PROJECT_VERSION}"
+ WORKING_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}")