aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2023-07-05 22:23:34 +0200
committerEgor Tensin <Egor.Tensin@gmail.com>2023-07-05 23:43:02 +0200
commitc374f169fdf79428d258faf59c1cdd800974994d (patch)
tree7e77b992c52ac9e7dca90065d1680d01630ec8bf /test/CMakeLists.txt
parentworker: actually stay offline (diff)
downloadcimple-c374f169fdf79428d258faf59c1cdd800974994d.tar.gz
cimple-c374f169fdf79428d258faf59c1cdd800974994d.zip
test: add a 2000-iteration basic repository test
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index b8a115c..e68ff45 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -16,9 +16,12 @@ function(add_python_tests name)
set_tests_properties("${name}" PROPERTIES TIMEOUT 300)
endfunction()
-add_python_tests(python_tests
- Python3::Interpreter -m pytest ${python_test_args})
+add_python_tests(python_tests_sanity
+ Python3::Interpreter -m pytest ${python_test_args} -m "not stress")
+
+add_python_tests(python_tests_stress
+ Python3::Interpreter -m pytest ${python_test_args} -m "stress")
add_python_tests(python_tests_valgrind
- Python3::Interpreter -m pytest ${python_test_args}
+ Python3::Interpreter -m pytest ${python_test_args} -m "not stress"
--valgrind-binary "${CMAKE_CURRENT_SOURCE_DIR}/../src/valgrind.sh")