aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt22
1 files changed, 14 insertions, 8 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 5d16f4e..66b79e9 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -1,11 +1,17 @@
find_package(Python3 REQUIRED COMPONENTS Interpreter)
-add_test(
- NAME integration_tests
- COMMAND Python3::Interpreter -m pytest
- "${CMAKE_CURRENT_SOURCE_DIR}"
- --server-binary "$<TARGET_FILE:server>"
- --worker-binary "$<TARGET_FILE:worker>"
- --client-binary "$<TARGET_FILE:client>"
- --project-version "${PROJECT_VERSION}"
+set(args
+ "${CMAKE_CURRENT_SOURCE_DIR}"
+ --server-binary "$<TARGET_FILE:server>"
+ --worker-binary "$<TARGET_FILE:worker>"
+ --client-binary "$<TARGET_FILE:client>"
+ --project-version "${PROJECT_VERSION}")
+
+add_test(NAME integration_tests
+ COMMAND Python3::Interpreter -m pytest ${args}
+ WORKING_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}")
+
+add_test(NAME integration_tests_with_valgrind
+ COMMAND Python3::Interpreter -m pytest ${args}
+ --valgrind-binary "${CMAKE_CURRENT_SOURCE_DIR}/../src/valgrind.sh"
WORKING_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}")